Cyberpunk 2077 - Epic has an issue
Incident Report for NVIDIA GeForce NOW
Resolved
The issue with Cyberpunk 2077 - Epic has been resolved.
Posted Jun 17, 2022 - 02:54 PDT
Investigating
We are currently working to resolve an issue affecting Cyberpunk 2077 - Epic.. We will make it available to play as soon as the issue is resolved.
Posted Jun 16, 2022 - 18:28 PDT
This incident affected: NVIDIA Global Services.