Palworld game saves issue

Incident Report for NVIDIA GeForce NOW

Investigating

The original cloud saves conflict issue was resolved. The drive error issue is being investigated. We continue working with Pocketpair Inc to resolve this issue.
Posted Aug 04, 2026 - 12:13 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 10:53 PDT

Identified

We are currently working with Pocketpair Inc to resolve an issue affecting Palworld.
Posted Jul 15, 2026 - 08:33 PDT