NPA-STR-SIN-01 partial outage
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 06, 2022 - 05:15 PDT
Investigating
We are currently investigating a partial outage happening in NPA-STR-SIN-01 zone. Some games may not be playable in that zone in the meantime.
Posted May 06, 2022 - 00:24 PDT
This incident affected: SG StarHub - Alliance Partner (NPA-STR-SIN-01).