Xbox Game Sync Issues

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 21:01 PDT

Identified

Microsoft's Azure service is currently experiencing an issue which is impacting GeForceNow's ability to sync some games between platforms. We appreciate your patience while this issue is being addressed.
Posted Oct 29, 2025 - 13:03 PDT
This incident affected: NVIDIA Global Services.