Clair Obscur Expedition 33 (Xbox) and Starfield Xbox games controller issue

Incident Report for NVIDIA GeForce NOW

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 10:50 PST

Investigating

We are currently working to resolve an issue affecting Clair Obscur Expedition 33 (Xbox) and Starfield. Games like Expedition 33 and Starfield may have Xbox controller issues where inputs keep switching between controller and mouse/keyboard. We are working to resolve the issue.
Posted Dec 02, 2025 - 19:22 PST