Network test - GeForce NOW encountered a problem

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 06:53 PDT

Monitoring

Fixes have been put into place and we will continue to monitor.
Posted Aug 06, 2025 - 14:49 PDT

Investigating

Some users may run into issues launching a session with the error "GeForce NOW encountered a problem".

We are currently investigating.
Posted Aug 06, 2025 - 12:19 PDT