World War Z: Aftermath is in maintenance mode
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 05:57 PDT
Investigating
World War Z: Aftermath is in maintenance mode due to an issue we found today. We are working to resolve it and make the game available to play again.
Posted Sep 21, 2021 - 11:59 PDT
This incident affected: NVIDIA Global Services.