Battlefield 2042 launch issues
Incident Report for NVIDIA GeForce NOW
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2023 - 11:20 PDT
Investigating
We are looking into reports of problems launching Battlefield 2042.
Posted Mar 17, 2023 - 16:06 PDT