Epic is Reporting Login Issues. GFN users are experiencing login issues for Fortnite and other games.

Incident Report for NVIDIA GeForce NOW

Resolved

Epic games login and GFN Account Linking have returned to normal.
Posted Nov 26, 2025 - 14:01 PST

Update

We are seeing problems launching other games which are using Epic Online Services or Easy Anti-Cheat. We are continuing to monitor for any further issues.
Posted Nov 26, 2025 - 11:41 PST

Monitoring

We are monitoring the situation. https://status.epicgames.com/. GFN Account Linking is impacted and users may also see errors when logging into specific epic games.
Posted Nov 26, 2025 - 10:16 PST
This incident affected: NVIDIA Global Services.