We have experienced an issue which caused queuing on some EU zones. The issue is contained. We are monitoring the situation.
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 24, 2024 - 21:11 PDT
Monitoring
We have experienced an issue which caused queuing on some EU zones. The issue is contained.
Posted May 24, 2024 - 16:55 PDT
This incident affected: NVIDIA Global Services.