Fortnite maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
Maintenance finished, Fortnite v22.00 is now available.
Posted Sep 18, 2022 - 05:57 PDT
Monitoring
Fortnite is undergoing scheduled maintenance for the v22.00 update: https://status.epicgames.com/

Fortnite will be available again via GeForce NOW when the maintenance finishes.
Posted Sep 18, 2022 - 00:43 PDT