Apex Legends is having issues
Incident Report for NVIDIA GeForce NOW
Resolved
Resolved- Apex Legends on Steam now launches properly. The game has been taken out of maintenance mode and is available to play.
Posted Feb 22, 2021 - 12:33 PST
Monitoring
Resolved- Apex Legends on Steam now launches properly. The game has been taken out of maintenance mode and is available to play.
Posted Feb 18, 2021 - 10:17 PST
This incident affected: NVIDIA Global Services.