We have experienced and issue which caused queuing on some zones. The issue is contained. We are monitoring the situation.
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted May 23, 2024 - 18:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2024 - 12:41 PDT
This incident affected: NVIDIA Global Services.