Global Outage for GeForce NOW. 06:33 AM PDT, 10/14/2020
Incident Report for NVIDIA GeForce NOW
Resolved
NVIDIA is glad to inform you that the recent issues with GeForce NOW are now resolved.
Posted Oct 14, 2020 - 08:33 PDT
Monitoring
NVIDIA is glad to inform you that the recent issues with GeForce NOW were mitigated. We are monitoring if there is any further impact.
Posted Oct 14, 2020 - 07:51 PDT
Update
We are continuing to investigate the issue. Thank you for your patience!
Posted Oct 14, 2020 - 07:29 PDT
Update
We are continuing to investigate the issue. Thank you for your patience!
Posted Oct 14, 2020 - 06:58 PDT
Investigating
NVIDIA regrets to inform you that we are experiencing issues with GeForce NOW. We are working on a solution and monitoring the impact. We will update this page every 30 minutes until the issues are resolved. Thank you for your patience!
Posted Oct 14, 2020 - 06:34 PDT
This incident affected: NVIDIA Global Services.