Battlefield 2042 in Maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 11:30 PDT
Monitoring
Battlefield 2042 Steam version is available to play. The game is currently only available in English, we are working on bringing back other languages support.
Posted Oct 18, 2023 - 14:45 PDT
Investigating
Battlefield 2042 Steam is currently in maintenance on GeForce NOW while we work with EA to integrate the new anti-cheat software that’s part of the Season 6 update. The EA App version is available to play again.
Posted Oct 11, 2023 - 11:36 PDT
This incident affected: NVIDIA Global Services.