GeForce NOW 1-month Priority Memberships Sold out in North America
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 13:32 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 13, 2023 - 09:50 PST
Monitoring
Due to increased demand, GeForce NOW 1-month Priority memberships are currently sold out in North America. Join the waitlist at www.geforcenow.com to have first access when they’re available. To help with capacity, Free membership sign ups have also been paused. This does not impact current members. 6-Month Priority memberships are still available.
Posted Dec 13, 2023 - 09:49 PST
This incident affected: NVIDIA Global Services.