EMEA: We are observing very high demand across GeForce Now

Incident Report for NVIDIA GeForce NOW

Update

We are continuing to work on a fix for this issue.
Posted Oct 10, 2025 - 14:22 PDT

Update

User errors in EMEA when launching the client have been addressed. Some features like install to play are currently disabled. We will continue to provide updates.
Posted Oct 10, 2025 - 13:19 PDT

Update

We are actively working to restore our users experience.
Posted Oct 10, 2025 - 12:48 PDT

Identified

We are actively working to restore the service experience.
Posted Oct 10, 2025 - 11:03 PDT

Update

We are actively working to resolve the issue.
Posted Oct 10, 2025 - 09:39 PDT

Investigating

Users are experiencing issues when connecting and loading content in the client. Please note the Install to Play feature has been temporarily disabled.
Posted Oct 10, 2025 - 09:05 PDT
This incident affects: NVIDIA Global Services.