Battlefield 6

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 08:58 PDT

Monitoring

The game has been patched and Season 1 + REDSEC are available to play

https://nvidia.custhelp.com/app/answers/detail/a_id/5732
Posted Oct 28, 2025 - 10:11 PDT

Investigating

We are currently patching Battlefield 6 for the Season 1 update.
Posted Oct 28, 2025 - 08:25 PDT