Destiny 2 in maintenance
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 17:24 PST
Investigating
We are currently working to resolve an issue affecting Destiny 2. We will make it available to play as soon as the issue is resolved.
Posted Nov 17, 2021 - 09:06 PST
This incident affected: NVIDIA Global Services.