GeForce NOW global outage
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Mar 10, 2024 - 17:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2024 - 15:05 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 10, 2024 - 13:02 PDT
Investigating
GeForce NOW is currently experiencing a global outage. We are working on a fix to bring back the service as soon as possible. Thank you for your patience!
Posted Mar 10, 2024 - 12:29 PDT
This incident affected: NVIDIA Global Services.