Lost Ark game is in maintenance

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 03:40 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2025 - 06:04 PST

Investigating

Lost Ark is in maintenance and is unavailable for play. We will make the game available to play as soon as the issue is resolved.
Posted Feb 12, 2025 - 10:33 PST