Epic is reporting login issues. GeForce NOW users are experiencing login issues for Fortnite

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Dec 24, 2025 - 21:40 PST

Monitoring

We are monitoring the situation. https://status.epicgames.com/. Users may also see errors when logging into specific Epic games.
Posted Dec 24, 2025 - 18:41 PST