Battlefield 6 on Steam now available, EA App coming soon.

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 17:10 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 10, 2025 - 17:10 PDT

Update

Battlefield 6 on Steam and Battlefield 6 on EA are available.
Posted Oct 10, 2025 - 12:28 PDT

Monitoring

Battlefield 6 on Steam now available, EA App coming soon.
Posted Oct 10, 2025 - 12:27 PDT
This incident affected: NVIDIA Global Services.