S.T.A.L.K.E.R. 2 PC Game Pass save problems
Incident Report for NVIDIA GeForce NOW
Update
We applied another fix on November 27 to increase the shut down time for the game to 10 minutes to ensure all saved games are preserved. Please send us Feedback in the GeForce NOW app if you continue to have problems.
Posted Nov 27, 2024 - 15:33 PST
Update
We applied another fix today to improve saved games. Please send us Feedback in the GeForce NOW app if you continue to have problems.
Posted Nov 25, 2024 - 15:10 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2024 - 15:21 PST
Investigating
We are aware of some users reporting problems losing saved games with S.T.A.L.K.E.R. 2 PC Game Pass version. We are investigating a fix.
Posted Nov 22, 2024 - 11:40 PST
This incident affects: NVIDIA Global Services.