Elevated latency in Bulgaria

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 13:33 PDT

Identified

Users connecting to the Bulgaria server location through Vodafone Greece (ISP) or Digi Romania (ISP) may experience elevated latency.
Posted Mar 20, 2026 - 12:12 PDT
This incident affected: Bulgaria [RTX 5080] (NP-SOF-02 [RTX 5080]).