Steam may be experiencing some issues

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 13:06 PDT

Monitoring

We are observing some reports of steam issues external to our GFN services. This may impact steam app and steam games launch on Geforce Now. No significant issues detected for GFN users at this time.
Posted Oct 23, 2025 - 11:47 PDT
This incident affected: NVIDIA Global Services.